Автор Тема: Работа ClipperCMS с PHP 5.5.4  (Прочитано 1290 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sadex13

  • Модератор
  • Разработчик
  • *****
  • Сообщений: 1097
    • Просмотр профиля
  • Версия modx: Evo 1.0.6, ClipperCMS 1.2.6
Работа ClipperCMS с PHP 5.5.4
« : 27 Октябрь 2013, 08:59:21 »
То что неизбежно должно было произойти случилось. В новой версии PHP 5.5.4 со старым депрекативным расширением mysql стали возникать проблемы:
http://www.clippercms.com/forum/installation/php-5-5-4/msg1212/#new

Для ClipperCMS решение проблемы имеется, надо просто переключиться на новое расширение mysqli. Поскольку в ClipperCMS по умолчанию установлено старое расширение  mysql, то перед инсталляцией Клиппера надо сделать следующее. В файлах:

/install/connection.collation.php
/install/connection.databasetest.php
/install/connection.servertest.php

вместо $database_type = 'mysql' поставить $database_type = 'mysqli'. После инсталляции Клиппера открыть файл:

/manager/includes/config.inc.php

и проделать там то же самое. Возможно, имеется либо появиться и более простой способ, но это только первый опыт работы ClipperCMS с PHP 5.5.4.

PS. Применение старого расширения mysql давно уже не рекомендуется в новых разработках сайтов на PHP/MySQL.
« Последнее редактирование: 27 Октябрь 2013, 09:03:30 от sadex13 »
FluxBB (PHP/MySQL) - легкий и быстрый форум для MODX с открытым кодом, минимальные требования к ресурсам.