Просмотр сообщений

В этом разделе можно просмотреть все сообщения, сделанные этим пользователем.


Сообщения - WiFr

Страницы: [1]
1
Посмотрел код и увидел, что движок меняет символ "&" на код "&".

Также после эксперимента стало понятно что меняются угловые скобки в "<br />" на следующий код "&lt;br /&gt;".



Неужели никто не использовал HTML код в Wayfinder и такая проблема не возникала больше ни у кого?

2
Обновил движок на сайте, с MODx evolution 1.0.5 на 1.0.15.
Возникла проблема, в текс меню на сайте добавляется HTML код.
В связи с тем, что текс некоторых пунктов меню длинный, необходимо между некоторыми словами или символами ставить неразрывный пробел. на 1.0.5 все отображалось нормально. Но после обновления в текст вставляется код. Видно на прикрепленном изображении.
Посмотрел код и увидел, что движок меняет символ "&" на код "&amp;".

Также после эксперимента стало понятно что меняются угловые скобки в "<br />" на следующий код "&lt;br /&gt;". Видно в следующем прикрепленном скриншоте.

Подскажите, что надо сделать, чтобы код не изменялся в меню при его формировании?

3
Обновил движок на сайте, с MODx evolution 1.0.5 до версии 1.0.15.
В визуальном редакторе Tinymce начала отображаться фоновая картинка, которая привязана в стилях к body.
До этого фон был белый, как и прописан для блока контента. А вернее даже для всех "all".
Мне же надо, чтобы фон был белый, как он отображается на сайте в блоке текста.
Долго с этим промучился но рецепта не нашел ни в интернете, ни сам.
Прописывал стили и даже создал отдельный CSS файл, где прописал белым фон и путь к файлу прописал в разделе "Интерфейс и представление". Это тоже не помогло.
Будьте добры, подскажите, что надо сделать, чтобы в Tinymce фон отображался белым, а не наследовал фон body?

Страницы: [1]