Автор Тема: Успешная работа Clipper 1.2 на сервере с PHP 5.4  (Прочитано 2235 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sadex13

  • Разработчик
  • *****
  • Сообщений: 1097
    • Просмотр профиля
  • Версия modx: Evo 1.0.6, ClipperCMS 1.2.6
Известно, что далеко не все приложения со старыми скриптами PHP (каковой, в частности, является MODX Evo официальной версии) могут без сбоев и багов нормально работать с PHP новых версий, от 5.3 и выше.
В то же время, команда Клиппера проделала немалую работу по обновлению старых скриптов MODX Evo в своем форке ClipperCMS. И эта работа дала свои результаты:
http://www.clippercms.com/forum/installation/testing-clipper-1-2-so-far-so-good/

Месяц тому назад, новая версия ClipperCMS 1.2 была успешно протестирована в следующей конфигурации в локале:
Windows 7, PHP 5.4.11, Apache 2.4, MySQL 5.5.29
При этом Evo 1.0.6 была успешно обновлена до  ClipperCMS 1.2. В новой   ClipperCMS нет проблем со старым депрекативным расширением mysql, поскольку там имеется блок API реализованный на новом mysqli.
Я думаю, что уже нет никакого смысла использовать русские сборки Evo 1.0.6+ со старым php-кодом времен 2004-2005 года, когда имеется совершенно новая ClipperCMS, на которую несложно перевести уже работающие сайты на MODX Evo. С учетом того, что ClipperCMS продолжает активно обновляться добросовестной командой разработчиков.
FluxBB (PHP/MySQL) - легкий и быстрый форум для MODX с открытым кодом, минимальные требования к ресурсам.

Оффлайн kp52

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
  • Версия modx: 1.0.6
Re: Успешная работа Clipper 1.2 на сервере с PHP 5.4
« Ответ #1 : 24 Июнь 2013, 12:57:13 »
Цитировать (выделенное)
там имеется блок API реализованный на новом mysqli

Стоит отметить, что ClipperCMS использует расширение mysqli только при включунии его через первую строчку config.inc.php:
$database_type = 'mysqli';
Зато стиль еще (пока-что) декларитивный. Сделал эту перемену на нескольких сайтах, работающих на РНР 5.4, без проблем.
 :) KP

Оффлайн sadex13

  • Разработчик
  • *****
  • Сообщений: 1097
    • Просмотр профиля
  • Версия modx: Evo 1.0.6, ClipperCMS 1.2.6
Re: Успешная работа Clipper 1.2 на сервере с PHP 5.4
« Ответ #2 : 24 Июнь 2013, 22:53:30 »
Стоит отметить, что ClipperCMS использует расширение mysqli только при включунии его через первую строчку config.inc.php

Приветствую, kp52. Не имеет принципиального значения, как включить расширение mysqli при необходимости. Главное что есть блок API для работы с БД через mysqli. Остальное - мелкие детали.
FluxBB (PHP/MySQL) - легкий и быстрый форум для MODX с открытым кодом, минимальные требования к ресурсам.